CCENT Flashcards Parts 1-3 Preview

Networking > CCENT Flashcards Parts 1-3 > Flashcards

Flashcards in CCENT Flashcards Parts 1-3 Deck (65):
1

line console 0

Global command that changes the context to console config mode

2

login

Line config mode. Tells IOS to prompt for a password (no username)

3

password *pass-value*

Line config mode. Sets the password required on that line for login if the *login* command (with no other parameters) is also configured

4

interface

Global command that changes the context to interface mode

5

hostname *hostname*

Global command that sets this switch's hostname, which is also used as the first part of the switch's command prompt

6

Ctrl+Z

Does the same thing as the *end* command

7

no debug all

Enable mode EXEC command to disable all currently enabled debugs

8

reload

Enable mode EXEC command that reboots the switch or router

9

write eraseerase startup-configerase nvram

Enable mode EXEC commands that erase the startup-config file

10

quit

Enable mode EXEC command that disconnects the user from the CLI session

11

disable

Moves the user from enable mode to user mode

12

configure terminal

Enable mode EXEC command that moves the user into config mode

13

show mac address-table

Shows all MAC table entries of all types

14

show mac address-table dynamic

Shows all dynamically learned MAC table entries

15

show mac address-table count

Shows the number of entries in the MAC table, and the total number of remaining empty slots in the MAC table

16

show mac address-table aging-time

Shows the global and per-VLAN aging timeout for inactive MAC table entries

17

clear mac address-table dynamic

Empties the MAC table of all dynamic entries

18

show interfaces status

Lists one line per interface on the switch, with basic status and operating information for each

19

Five required setting in order to configure an emulator for

- 9600 bits/second- No hardware flow control- 8-bit ASCII- No parity bits- 1 stop bit

20

Three reasons a switch will remove entries from the MAC addr

Age- Table filling- User command

21

login local

Console and vty config mode. Tells IOS to prompt for a username and password, to be checked against locally configured *username* global configuration commands on this switch or router

22

username *name* secret *pass-value*

Global command. Defines a username and password combination (there could be many), used for authentication. Used when the *login local* line config command has been used

23

crypto key generate rsa

Global. Creates and stores the keys required for SSH

24

transport input {telnet ssh all none}

vty line config mode. Defines whether telnet and/or ssh access is allowed into the switch. Both allowed by default

25

ip address *ip-address* *subnet mask*

VLAN interface mode. Statically configures the switch's IP address and mask

26

ip address dhcp

VLAN interface mode. Configures the switch as a DHCP client to discover its IPv4 address, mask, and default gateway

27

ip default-gateway *address*

Global command. Configures the switch's default gateway IPv4 address

28

enable secret *pass-value*

Global command. Sets this switch's password that is required for any user to reach enable mode

29

history size *length*

Line config mode. Defines the number of commands held in the history buffer

30

logging synchronous

Console or vty mode. Tells IOS to send log messages to the user at natural break points between commands rather than in the middle of a line of output

31

[no] logging console

Global command that disables or enables the display of log messages to the console

32

exec-timeout *minutes*

Console or vty mode. Sets the inactivity timeout

33

show dhcp lease

Lists any information the switch acquires as a DHCP client

34

show ip ssh

Lists status information for the SSH server, including the SSH version

35

show ssh

Lists status information for current SSH connections into and out of the local switch

36

show history

Lists the commands in the current history buffer

37

How is speed chosen by Cisco autonegotiation?

Sense the speed, if that fails, use the IEEE default (slowest supported speed, of 10M)

38

How is the duplex setting chosen by Cisco autonegotiation?

Use the IEEE defaults: If speed = 10 or 100, use half duplex; otherwise use full duplex

39

interface range type port-endport

Changes the context to interface mode for a range of consecutively numbered interfaces

40

speed {10 100 1000 auto}

Interface mode. Disables or enables the interface

41

duplex

Interface mode. Maually sets the speed of the interface

42

no speedno duplexno description

Reverts to the default setting for each speed, duplex, and description

43

switchport mode {access truck}

Interface mode. Tells the switch interface to always be an access port or always be a trunk port

44

switchport port-security mac-address mac-address

Interface mode. Adds a specific MAC as an allowed MAC address on the interface

45

switchport port-security mac-address sticky

Interface mode. Tells the interface to learn MAC address and then add them to the configuration for the interface as a secure MAC address

46

switchport port-security maximum value

Interface mode. Sets the maximum number of static secure MAC addresses that can be assigned to a single interface

47

switchport port-security violation {protect restrict shu

Interface mode. Telss the switch what to do if an inappropriate MAC address tries to access the network through a secure switch port

48

show mac address-table secure

Lists MAC address defined or learned on ports configured with port security

49

show mac address-table statis

Lists static MAC addresses and MAC address learned or defined with port security

50

show port-security interface

Lists and interface's port security confiiguration settings and security operational status

51

show port-security

Lists one line per interface that summarizes the port security settings for any interface on which it is enabled

52

Describe the difference switchport modes:- access- trunk- dynamic desirable

access - Always act like an access port ; trunk - Always act like a trunk port ; dynamic desirable - Initiates negotiation messages and responds to negotitation messages to dynamically choose whether to start trunking

53

vlan *vlan-id*

Global config command that both creates the VLAN and puts the CLI into VLAN config mode

54

vtp mode {server client transparent off }

Global command that defines the VTP mode

55

switchport access vlan *vlan-id*

Interface subcommand that statically configures the interface into that one VLAN

56

switchport trunk encapsulation {dot1q isl negotiate}

Interface subcommand that deines which type of trunking to use

57

switchport trunk native vlan *vlan-id*

Interface subcommand that defines the native VLAN for a trunk port

58

switchport nonegotiate

Interface subcommand that disables the negotiation of VLAN trunking

59

switchport voice vlan *vlan-id*

Interface subcommand that fines the voice VLAN on a port, meaning that the switch uses 802.1Q tagging for frames in this VLAN

60

switchport trunk allowed vlan {add all except remove} *vlan-list*

Interface subcommand that defines the list of allowed VLANs

61

show interfaces *interface-id* switchport

Lists information about any interface regarding admin settings and operational state

62

show interfaces *interface-id* trunk

Lists information about all operational trunks (but no other interfaces), including a list of VLANs that can be forwarded over the trunk

63

show vlan {brief ; id *vlan-id* ; name *vlan-name* ; summary}

Lists information about the VLAN

64

show vlan *vlan*

Displays VLAN information

65

show vtp status

Lists VTP configuration and status information