Cisco CLI Flashcards

1
Q

How to enter priviledged EXEC mode ?
How to enter global configuration mode ?

A

SWI>enable
SWI#configure terminal

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
2
Q

How to create a password on Cisco device ?

A

enable password [pass]

or

enable secret [pass]

(more secure and takes precedence over enable password)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
3
Q

How to display running and starting configuration ?

A

show ____-config
show running-config
show startup-config

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
4
Q

How to save configuration ?

A

1 “write”
2 “write memory”
3 “copy running-config startup-config”

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
5
Q

How to encrypt passwords ?

A

service password-encryption
(Encrypts current and future passwords. Uses Cisco proprietary type 7 encryption. Not secure can be cracked)

enable secret _____
(more secure. Uses MD5 encryption, harder to crack. Passwords are always encrypted)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
6
Q

How to remove a command ?

A

type “no” in front of command you want to remove (global config mode)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
7
Q

You use the […] keyword to execute privileged EXEC commands in global configuration mode.

A

do

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
8
Q

How to change hostname of Cisco device ?

A

hostname [name]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
9
Q

How to view mac address table ?

A

show mac address-table

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
10
Q

How to clear mac address table ?

A

clear mac address-table dynamic

clear mac address-table dynamic interface (mac or port)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
11
Q

How to view interface info on router ?

A

show ip interface breif

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
12
Q

How to configure interface on router ?

A

interface (interface)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
13
Q

How to manually set ip address for interface ?

A

ip address (IP address) (subnet mask)

no shutdown

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
14
Q

How to configure interfaces in a range ?

A

interface range (range)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
15
Q

How to configure router static path to next hop ?

A

ip route (ip address) (netmask) (next hop ip address)

ip route (ip address) (netmask) (exit interface)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
16
Q

Cisco Default Serial Connection Setting

A

Speed (baud): 9600
Data bits: 8
Stop Bits: 1
Parity: None
Flow Control: None

17
Q

How can you view all the availible commands in your current user mode ?

A

type ‘?’ in the CLI

18
Q

How to configure a VLAN ?

A

vlan [vlan-id ]

19
Q

show VLAN status ?

A

show vlan brief

20
Q

What is portfast?
How to enable portfast on an interface?
How to enable it on all (access) ports?

A

Portfast should only be configured on ports connected to a host (PC). It will only work on an access port. It bypasses the ‘Listening’ and ‘Learning’ stage of STP going straight to a forwarding state.

SWI(config)#interface g0/0
SWI(config-if)#spanning-tree portfast

SWI(config)#spanning-tree portfast default

21
Q

What is BPDUGuard ?
How to enable bpduguard on an interface?
How to enable it on all (access) ports?

A

BPDUGuard is an extra safe guard on the port. If a port with BPDUGuard recieves a BPDU from another switch, the interface will shutdown to prevent a loop from forming.

SWI(config)#interface g0/0
SWI(config-if)#spanning-tree bpduguard enable

SWI(config)#spanning-tree portfast bpduguard default

22
Q

How to set a primary and secondary root bridge manually in different VLANs ?

A

SWI(config)#spanning-tree vlan 1 root primary
SWI(config)#spanning-tree vlan 2 root secondary

(What really happens behind the scenes is that the priority of the bridges are changed)
SWI(config)#spanning-tree vlan 1 priority 28672

23
Q

How to set a spaning tree link type on an interface ?

A

SWI(config-if)#spanning-tree link-type [type]
point-to-point (full duplex)
shared
edge (portfast enabled)

24
Q

How to check EtherChannel load balance method ?
How to change it ?

A

ASWI#show etherchannel load-balance

ASWI(config)#port-channel load-balance [type]
dst-ip / dst-mac / src-dst-ip / src-dst-mac / src-ip / src-mac

25
Q

How to configure etherchannel modes ?

A

ASWI(config-if-range)#channel-group [group] mode [mode]
active (LACP) / auto (PAgP if detected) / desirable (PAgP) / on (etherchannel only) / passive (LACP if detected)

to configure etherchannel on routed ports first configure the ports to be routed ports then assign the IP address to the port-channel.
ASWI(config-if-range)#no switchport
ASWI(config-if-range)#channel-group 1 mode [mode]
ASWI(config-if-range)#interface po1
ASWI(config-if)#ip address [IP] [subnet]

26
Q

Show info on the etherchannel

A

ASWI#show etherchannel summary
ASWI#show etherchannel port-channel

27
Q

How to enable RIP Routing protocol on router ?

A

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary (prevents classful addressing)
R1(config-router)#network [classful network]
(tells the router which interfaces to activate RIP on)
R1(config-router)#passive-interface [int not connected to RIP neighbors]
R1(config-router)#default-information originate (advertise default route)

28
Q

How to view the routing protocol being used ?

A

R1#show ip protocols

29
Q

How to enable EIGRP ?

A

R1(config)#router eigrp [AS number]
R1(config-router)#no auto-summary (prevents classful addressing)
R1(config-router)#passive-interface [int not connected to RIP neighbors]
R1(config-router)#network [classful network]
(tells the router which interfaces to activate RIP on)
R1(config-router)#default-information originate (advertise default route)

30
Q

How to make a loopback interface ?

A

R1(config)#interface loopback [num]
R1(config-if)#ip address [IP] [/32]

31
Q

How to configure OSPF ?

A

R1(config)#router ospf [ID] (can be any number, only locally significant)
R1(config-router)#network [IP] [wildcard] area [area num]

can also enable on interface
R1(config)#interface [interface]
R1(config-if)#ip ospf [id] area [area]

R1(config-router)#passive-interface [interface]
(tells router to stop sending ospf hello messages out of a specific interface)

R1(config-router)#default-information originate (advertise default route)

32
Q

View OSPF information

A

R1#show ip protocols
R1#show ip ospf database
R1#show ospf neighbors
R1#show ospf interface

33
Q

How to change the reference bandwidth for OSPF cost ?

On an interface ?

A

R1(config-router)#auto-cost reference-bandwidth [Mbps]
(should configure the same bandwidth on all OSPF routers in the network)

R1(config)#interface [interface]
R1(config-if)#ip ospf cost [Mbps]

34
Q

Command to enable IPv6 Routing on a router ?

A

R1(config)#ipv6 unicast-routing
R1(config)#int [interface]
R1(config-if)#ipv6 address [address/mask]
R1(config-if)#no shutdown

35
Q

How to apply an access control list to an interface ?

A

R1(config-if)#ip access-group [number] {in / out}

36
Q

How to create Standard Named Access Lists ?

A

R1(config)#ip access-list standard [acl-name]

R1(config-std-nacl)#[number] {allow / deny} [IP] [wildcard]