EIGRP Flashcards Preview

CCNP Route > EIGRP > Flashcards

Flashcards in EIGRP Deck (138):
1

Are keys case sensitive?

Yes

2

If there are multiple valid, matching keys, which key will be used?

The one with the lowest number (first match)

3

Give the command to display a key chain

show key chain

4

What are the two ways to add interfaces to EIGRP and what are the administrative distances for these?

network command - Internal route - AD 90
redistribute connected command - External route - AD 170

5

What two things does "passive-interface" do?

It stops the interface from sending Hello packets and will also ignore incoming ones.

6

Give the command to set all interfaces as passive except Ethernet0/0

router eigrp
passive-interface default
no passive-interface Ethernet0/0

7

What command will show EIGRP interfaces in passive mode?

sh ip protocols

8

Which K-values are used in the default metric?

bandwidth (k1) and delay (k3)

9

How is the router-id chosen?

The highest numbered active loopback is used, or the highest numbered active interface if no loopback is available.

10

Can two routers with the same router-id become neighbors? Can they exchange routes?

They can become neighbors but cannot exchange routes if directly connected to each other. They will accept internal routes if there is another router between the two.

11

Give the command to manually set a router-id

router eigrp 100
eigrp router-id X.X.X.X

12

What extra information does an external route update include?

It includes the originating router's router-id as well as the external metric and protocol.

13

Give the command to disable split-horizon for EIGRP on an interface.

interface serial0/0
no ip split-horizon eigrp

14

What does the following command do?
interface serial0/0
no ip split-horizon

It will disable split-horizon for RIP only.

15

How much bandwidth total will EIGRP use on a given link?

By default, EIGRP uses only 50% of the available bandwidth.

16

Give the command to change the percentage of bandwidth EIGRP will use on interface serial0/0.

interface serial0/0
ip bandwidth-percent eigrp

17

Explain the difference between access-rate and CIR.

Access rate is the fastest rate a connection can physically handle. Committed information rate (CIR) is the guaranteed available rate.

18

Does the bandwidth command set the access rate or the CIR? Without it, what is used?

It sets the CIR. Without the bandwidth command, the CIR defaults to the access rate.

19

What unit does the bandwidth command use?

kilobits per second

20

What is the assumed bandwidth rate on a serial interface unless otherwise specified?

1544 kbps

21

What should the bandwidth command be set to for point-to-point and multipoint links?

On point-to-point, use bandwidth to set the CIR. On multipoint, set bandwidth to the sum of all the CIRs.

22

How does EIGRP determine the available bandwidth in multipoint links?

Bandwidth should be set to the sum of the CIRs. EIGRP will divide this by the number of PVCs, and use 50% of that value for each connection.

23

What impact does "set ip bandwidth-percent" have on a multipoint link?

EIGRP will divide the number given by the number of PVCs.

24

How is the reported distance sent?

The sending router sends the raw values and the receiving router calculates the reported distance (RD).

25

How does as a receiving router calculate the feasible distance?

It adds the delay for the distance to the sending router, and also replaces the bandwidth value if the bandwidth between it and the sending router is slower than the current minimum bandwidth, then recalculates.

26

What are the values given as (x, y) in "show ip eigrp toplogy"?

(feasible distance, reported distance)

27

What unit is used in the "delay" command on an interface? What unit is displayed with "show interface"?

The delay command uses tens of microseconds but the show command will display it in microseconds.

28

What are the two ways of manipulating EIGRP metrics?

1) Change delay and/or bandwidth
2) Use an offset-list

29

Of delay and bandwidth, which is preferred to modify?

Delay is preferred, because other protocols also use the bandwidth command.

30

Does changing the delay or bandwidth impact a sending neighbor's reported distance?

No

31

What are the two ways of matching all ip addresses with an off-set list?

Use any/any in the access-list, or reference access-list 0.

32

Does adding/removing an offset-list cause adjacencies to drop?

Yes

33

What does "sh ip eigrp topology" show by default? Give the command to see everything in the topology table.

It shows only successors and feasible successors.

sh ip eigrp topology all-links

34

What does an inbound versus an outbound offset-list do?

An inbound list changes the router's local value plus the value it will report.

An outbound list changes only the reported value.

35

On the packet level, how is an offset-list implemented?

As delay

36

Can an offset-list decrease the value of the EIGRP metric?

No

37

What are the the conditions for choosing a feasible successor?

The feasible successor must have the same AD metric as the successor, and must satisfy the feasible condition. The feasibility condition states the feasible successor's reported distance must be less than the successor's feasible distance.

38

What does a Query include?

The query includes poisoned route information, including a maximum bandwidth and infinite delay.

39

What does a negative reply to a query include?

The reply includes a router-id with all zeros and a different value for the type of network. The delay is also maxxed out.

40

What is the active timer?

The active timer is the amount of time before a neighbor that doesn't respond to a query is considered Stuck in Active and the adjacency is torn down.

41

What is the default active timer value?

The default active timer value is 3 minutes.

42

How much time must elapse before a SIA Query is sent to a non-responsive neighbor?

Half of the active timer value, so roughly 90 seconds by default.

43

What happens if a router receives an answer to a SIA Query?

If the neighbor sends back a SIA Reply, the active timer will be reset.

44

If a route is lost, what happens to it while the router goes through the Active route process?

The stale route remains in the routing table.

45

What are two ways to limit the scope of EIGRP active route queries?

Stub routers and router summarization

46

What is a stub router?

A stub router will not advertise learned routes amongst its neighbors by default. Other routers will also not send Query packets to it.

47

Give the command to change the default active timer to one minute.

router eigrp 100
timers active-time 1

48

By default, what will a stub router advertise?

It will advertise only connected and summary routes by default.

49

Give the command to set a router as a stub router that will advertise its redistributed routes as well as the default options.

router eigrp 100
eigrp stub connected summary redistributed

50

What options does an offset-list take for input?

Standard access-list only

51

What is the netmask for matching all bits?

255.255.255.255

52

What is the syntax to match all routes on a prefix-list?

0.0.0.0/0 le 32

53

What does variance enable?

Variance allows the installation of unequal cost routing paths into the routing table. By default, it is set to 1, meaning it only allows equal paths.

54

How is an extended ACL interpreted when used as a distribution list?

The source is evaluated as the sending neighbor IP address, and the destination is evaluated as the prefix in the update.

55

What is a distribute-list used for?

It can limit which routes are accepted and/or sent to neighbors.

56

When can a route be added as an unequal cost path to the routing table?

It must be a feasible successor route, and the reported distance must be less than the successor's feasible distance multiplied by the variance.

FS's RD greater than Successor's FD * variance

57

What is the netmask octet for match?

255

58

What command will show any distribute-list filters that are impacting EIGRP?

sh ip protocols

59

What must the relationship of the ge or le number be to the CIDR notation number?

They cannot be lower or equal to the length on the CIDR notation.

60

Does adding a distribution list cause adjacencies to go down?

Yes

61

How does auto-summarization impact the number of queries?

The neighbors of the auto-summarization router will not query other neighbors if the route becomes unreachable. So, queries stop at one hop beyond the summarizing router(s).

62

Give the command to enable the maximum number of equal-cost paths that EIGRP can support.

router eigrp 100
maximum-paths 6

63

If no ge or le is specified, what value is used for the subnet mask?

The /# is used first for the number of interesting bits to match on, and then used again for matching the subnet mask.

64

What is the wildcard octet for ignore?

255

65

What is the wildcard mask for ignoring all bits?

255.255.255.255

66

Give the command to set variance to three.

router eigrp 10
variance 3

67

What happens if a distribute-list references a non-existent ACL?

It will have no impact.

68

What is the syntax to match a default route in a prefix-list?

0.0.0.0/0

69

Does ge or le come first in a prefix-list statement?

ge

70

What three options will the distribute-list command take as a source?

access-list, prefix-list, or route-map

71

What is the netmask octet for ignore?

0

72

What is the netmask for ignoring all bits?

0.0.0.0

73

Give the syntax for a prefix-list entry.

ip prefix-list MyList seq 10 ...

74

What is the wildcard mask for matching all bits?

0.0.0.0

75

Give the prefix-list notation to deny all incoming prefixes that have the first three octets of 10.10.10.x and a subnet mask between 24 and 30.

ip prefix-list MyList seq 10 deny 10.10.10.0/24
ip prefix-list MyList seq 10 deny 10.10.10.0/24 ge 25 le 30

76

What additional functionality does a prefix-list add over an access-list?

The ability to match on the subnet mask as well as the prefix.

77

What is the wildcard octet for match?

0

78

Are prefix-list names case sensitive?

Yes

79

Give the command to apply a prefix-list for route filtering.

router eigrp 100
distribution-list prefix in/out

80

What impact will a route-map without a match statement have?

It will match everything.

81

Give the command to match an ACL within a route-map.

route-map Test permit 10
match ip address 101

82

What will the sequences numbers be for the following input?route-map INE permitroute-map INE deny

The permit will be overwritten, leaving only -

route-map Test deny 10

83

Give the command to match a prefix-list within a route-map.

route-map Test permit 10
match ip address prefix-list MyList

84

What direction to permits/denies work in a distribute-list?

Addresses must match the distribute list, or they are filtered.

85

Can a distribution list be entered without specifying direction?

No

86

Give the command to apply a route-map for route filtering.

router eigrp 100
distribute-list route-map INE in/out

87

Which EIGRP routers can perform summarization?

Any router

88

Where is EIGRP summarization configured?

On the interface

89

Give the command to summarize 10.0.0.0/8.

interface Serial0/0
ip summary-address eigrp 100 10.0.0.0 255.0.0.0

90

Which of the following results in dropping the adjacency: adding, removing, or changing a prefix-list?

All three

91

Can an interface have multiple summary addresses?

Yes

92

What side effect occurs as a result of adding a summary route?

The route will add the summary as a directly connected route to the network to its Null0 interface.

93

Are summary routes internal or external? What is the AD?

Internal; 90

94

What are three criteria for auto-summarization to occur?

1. The network must be local to the router.
2. The network must be defined with "network ..." rather than redistributed.
3. The sending interface must not be part of the summarized networks.

95

Give the command to show auto-summarizations in effect.

show ip protocols

96

Give the three ways to send a default route through EIGRP.

Redistribution of a static route, summarization, or configuration of a default classful network

97

What are two ways the default network can make it into the routing table through EIGRP?

There must be a static route with static redistribution, or the default network must already be an EIGRP-advertised route.

98

Give the command to set the default network.

ip default-network x.x.x.x

There is no mask since the network must be classful.

99

Give the command to summarize a default route.

interface Serial0/0
ip summary-address eigrp 0.0.0.0 0.0.0.0

100

What is a side effect of adding a summary-address statement on an interface?

No other routes will be advertised, except for other summary routes.

101

What is DUAL?

Diffusing Update ALgorithm

102

What kind of algorithm is EIGRP?

advanced distance vector

103

What address are EIGRP updates sent to?

In a multiaccess network, multicast address 224.0.0.10

In a point-to-point network, individual neighbor IP

104

What layer 4 protocol does EIGRP run on?

IP protocol 88

105

Name the five EIGRP packet types.

Hello, Query, Reply, Update, ACK

How queer Randy usually acts!

106

Which packets require an ACK?

Update, Query, and Reply
(everything except Hello and ACK)

107

What are RD and FD?

Reported distance (RD) is the neighbor's metric for the route. Feasible distance (FD) is the advertised distance, plus the distance from this router to the neighbor.

108

How is EIGRP unlike other distance vector algorithms?

It only sends updates on change, and maintains relationships using hellos.

109

What does EIGRP use for metric calculation by default?

bandwidth and delay

110

What are the three steps to EIGRP neighbor convergence?

1. Formation of neighbor relationship
2. Exchange of routes to populate the topology table
3. Run DUAL and populate the routing table

111

What is an AS?

An autonomous system is a collection of networks under one centralized administrative control entity.

112

What purpose do Hello packets serve?

They discover new neighbors and maintain existing relationships.

113

List the three classful network ranges.

Class A - anything before 127
Class B - anything after A and before 192
Class C - anything after B and before 224

114

What is the hold time, where is it advertised, and what value does it use by default?

The hold time is amount of time before a neighbor marks this router as dead. It is included in the Hello packet.

The default hold time is 3 x hello interval. On LAN links, this is 15 seconds. On T1 or slower, this is 180 seconds.

115

How are EIGRP routes indicated in the routing table?

D for interior routes and EX for exterior routes

116

List the process for forming a neighbor relationship.

1. Both neighbors send unicast Hellos
2. Each sends a unicast Update packet that is empty but has the Init flag set
3. Each sends a unicast Update that contains the entire routing table
4. Each neighbor ACKs the Updates.

117

What does a "retry limit exceeded" indicate?

This router is sending unicast Update packets with the initialization bit set in order to form an adjacency, but it is not receiving a response from the neighbor.

118

How are Hello and ACK packets related?

ACK packets are just Hello packets that are sent unicast and have a number in the acknowledge field.

119

What is the side effect of adding a static neighbor?

Multicast is disabled on that interface.

120

Name five requirements for forming a neighbor adjacency.

The interfaces must be able to reach each other.
The interfaces must not be in passive mode.
Authentication must match.
K-values must match.
AS must match.

121

In an interface with a primary and secondary ip address, which address(es) will EIGRP communication originate from?

primary IP only

122

What does this error message indicate?

"Neighbor is blocked: not on common subnet"

The router is receiving packets from an address on a subnet that it does not have directly connected on that interface.

123

What is the error message for mismatched AS values?

There is no error. It fails silently.

124

What is the command to set non-standard K-values?

router eigrp 100
metric weights k1 k2 k3 k4 k5

125

How often are Hello packets sent by default?

5 seconds on a LAN or 60 seconds on a T1 or slower

126

What is the command to change how often hello packets are sent?

interface Gigabit0/0
ip hello-interval eigrp #

127

What are the default hold timers?

Three times the hello time by default.

15 seconds on a LAN and 180 seconds on a T1 or slower

128

What is the command to set the hold timer?

interface Gigabit0/0
ip hold-timer eigrp #

129

What impact does updating the hold-timer on an interface have?

The router will send a different dead timer in its Hello packets, and its neighbor will wait that many seconds before marking it down.

130

What command will show non-default hello intervals (and hold timers on newer versions of IOS)?

sh ip eigrp interface detail

131

What kinds of authentication does EIGRP support?

MD5 only

132

Give the commands to create a keychain called MyKeys with a password of supersecret.

key chain MyKeys
key 1
key-string supersecret

133

Give the commands to apply the keychain called MyKeys to interface GigabitEthernet0/0

interface GigabitEthernet0/0
ip authentication mode eigrp md5
ip authentication key-chain eigrp MyKeys

134

Which parts of authentication have to match to form a neighbor relationship?

The key number and key-string.

The key chain name does not have to match.

135

Give the command to disable split-horizon.

interface Gigabit0/0
no ip split-horizon eigrp

136

How will a router respond to a Query for a network it has never seen?

It will reply back in the negative.

137

How will a router respond to a Query that it has an alternate route to?

The router will reply with the alternative route.

138

How will a router respond to a Query for a network that previously existed through the querying router?

It will propagate the query.