OSPF Flashcards Preview

CCNP Route > OSPF > Flashcards

Flashcards in OSPF Deck (118):
1

What layer 4 protocol does OSPF use?

IP protocol 89

2

What address does OSPF send to?

224.0.0.5

On a segment with a DR, routers send multicast updates to 224.0.0.6.

3

What unit belongs to an area?

A link (interface)

4

What is area zero?

Area zero is the backbone. Updates to other areas must flow through area zero to be transmitted.

5

What is a type 1 LSA?

A type 1 router LSA is sent by all routers to describe their links. It is flooded to all routers in an area.

6

What happens if a router receives a new LSA?

It must rebuild its database and re-run the SPF algorithm.

7

What is an ABR?

Area border routers (ABR) span multiple areas, one of which must be the backbone area zero.

8

What is the LSDB?

The link state database (LSDB) is the name of the OSPF topology database.

9

How are the LSDBs of routers in the same area related?

They must all match within an area.

10

How do routers learn of routes in other areas?

The ABR floods a type 3 summary LSA into the area.

11

How is the OSPF process id significant?

It is only locally significant and does not have to match between neighbors.

12

What happens if a route matches multiple network statements with different areas?

The most specific network statement will win.

13

What command will show the areas that interfaces belong to?

sh ip ospf interfaces

14

How is the router-id determined?

The highest up/up loopback interface IP address is used, or the highest up/up physical address if no loopback is available.

15

What will make a router-id change go into effect?

If the router has no neighbors, it becomes immediately active.

Otherwise, the ospf process or the router must be reloaded.

16

What does "2WAY" neighborship indicate?

The routers are adjacent but have not exchanged topology information. This will occur on networks with a DR.

17

What side effect does adding an OSPF command to an interface have?

It will create the router configuration for that OSPF process if none exists.

18

What five things must match for a full adjacency to form?

Hello and dead interval
Area ID
Subnet mask and MTU of the shared link
Stub area flag
Authentication

19

On a multiaccess link, what additional information do Hellos include?

The hello packet includes the router-ids of all neighboring routers and the IP addresses of the DR and BDR.

20

Give the command to show the OSPF timers on an interface.

sh ip ospf interface s0/0

21

Give the commands to set the hello and dead intervals on an interface.

interface Serial0/0
ip ospf hello-interval #
ip ospf dead-interval #

22

How can sub-second hello timers be configured?

interface Serial0/0
ip ospf dead-interval minimal hello-multiplier $x

Where $x is the number of Hellos per second.

23

What is a better option for sub-second convergence than sub-second hello timers?

Bidirectional forwarding detection (BFD)

24

Can two routers with the same router-id become neighbors?

No, and they will not accept each others' LSAs.

25

What behavior will result from a mismatch in MTU sizes?

The routers will get as far as EXSTART and then go down before they exchange LSAs. A log message will state the neighborship went from "EXSTART to DOWN: too many retransmissions."

26

Where is the MTU for a link advertised?

In the database description packets sent after the Hellos during adjacency formation.

27

Give the OSPF states completed to form full adjacency.

Down
Attempt (static neighbor only)
Init
2-way
Exstart
Exchange
Loading
Full

Do I need 2 entertain every leaving faculty?

28

List the OSPF authentication types.

0 - no authentication
1 - plain text
2 - MD5

29

What error message is displayed for mismatched authentication?

No error is displayed, only debug messages.

30

Which OSPF packets include authentication information?

The authentication information is in the header of every packet.

31

What determines the OSPF network type?

layer 2 encapsulation

32

What is the default network type for Ethernet?

broadcast

33

What is the default network type for a physical interface configured with frame-relay encapsulation?

non-broadcast (multiaccess)

34

What network types are available for frame relay sub-interfaces?

"point-to-point" or "multipoint" (point-to-multipoint NBMA)

35

What is the metric cost for a T1 link?

64

36

What is the metric cost for an ethernet link?

10

37

What is the metric cost for a fast ethernet link?

1

38

How is metric cost calculated?

Reference-bandwidth divided by interface bandwidth

10^8 (100,000,000) / bandwidth in bits

39

Name the five OSPF packet types.

1. Hello
2. Database description
3. Link state request
4. Link state update
5. Link state acknowledgement

40

What is contained in a hello packet?

router-id, router priority, area, neighbors, DR and BDR, hello and dead intervals, authentication, and stub area info

41

How is the DR determined?

By the highest router priority, then highest router-id

42

What is the default router priority?

1

43

Give the command to set the router priority.

interface Ethernet0/0
ip ospf priority #

44

Give the command to view all type 2 LSAs.

sh ip ospf database network

45

What is the first LSA sequence number?

80 million (80,000,000) in hex

46

Give the command to limit the number of LSAs.

router ospf 1
max-lsa #

47

What happens if the maximum number of LSAs is reached?

The router will send a notification message when the maximum is reached, then a warning when it's exceeded. After one minute of exceeded LSAs, it will tear down all adjacencies and go silent on all OSPF interfaces for that process for the duration of the ignore-time configured.

48

What does an ATTEMPT status indicate?

This is only seen with statically configured neighbors. The router has begun sending hellos but has not yet received anything in return.

49

What does an INIT status indicate?

The router has received a hello from the neighbor but did not see its own router-id listed in the neighbors.

50

What does a 2WAY status indicate?

The router has received a hello from the neighbor that included its own router-id. This is the furthest any router will go with a non-DR/non-BDR router on a multiaccess segment.

51

Under what types of networks does OSPF elect a DR/BDR?

On any multiaccess networks - broadcast or non-broadcast

52

What does an EX-START status indicate?

The first database description has been sent

53

Give a high-level summary of the steps involved in becoming fully adjacent, starting after 2WAY status.

Each router sends database descriptions (summaries), looks for LSAs in the neighbors' descriptions that are unknown or newer, requests those interesting LSAs, and sends any LSAs requested.

54

What occurs in the EX-START state?

The first database descriptions are sent. These are empty with the init bit set and are used for the purposes of determining master/slave. The higher router-id will also become the master and generate the first sequence number, which both will use.

55

Are database descriptions sent unicast or multicast?

unicast

56

What occurs in the EXCHANGE state?

Both routers send their database descriptions. Each one includes the More bit until the last one, and all LSA descriptions have been sent.

57

What occurs in the LOADING state?

The routers sent unicast link stat requests, then receive unicast LSUs with the requested LSAs. These are acknowledged.

58

Which routers listen on 224.0.0.6?

The DR and the BDR

59

Which routers listen on 224.0.0.5?

All OSPF routers, including DR and BDR

60

Which addresses are used when a router needs to share an update in a multiaccess network?

The originating router sends the update to 224.0.0.6, then the DR sends an update to 224.0.0.5. The receiving routers ACK to 224.0.0.6, except the BDR, which ACKs to 224.0.0.5.

61

Give the order for route selection priority.

My area, inter-area, external type 1, external type 2, nssa type 1, nssa type 2

O > IA > EX1 > EX2 > N1 > N2

62

Does receiving a type 3 LSA force a SPF recalculation?

No

63

Give three ways to change the OSPF cost.

change the reference bandwidth, set the bandwidth of an interface, or change the cost directly

64

What is the default reference bandwidth and value?

FastEthernet - 10^8 or 100,000,000 (100 million)

65

Bandwidths above which speed are all cost one?

FastEthernet and above

66

Give the command to change the reference bandwidth.

router ospf 100
auto-cost reference-bandwidth

67

Give the command to change the cost of an interface.

interface FastEthernet0/0
ip ospf cost #

68

Give the command to show the cost of all interfaces.

sh ip ospf interface brief

69

What impact do in and out filtering have on an ABR?

Inbound filtering will stop the type 3 summary LSA from being sent to any other areas. Outbound filtering will stop the type 3 summary LSA from being sent to a specific area.

70

If an ABR performs filtering, what action will this cause?

This will stop the Type 3 LSA from being formed and flooded out.

71

Give the command to filter on an ABR.

router ospf 100
area # filter-list prefix in/out

72

In a prefix-list being used with the filter-list command, what actions occur with "permit" and "deny"?

Permit will allow type 3 summary LSAs to be created; deny will not allow them to be created

73

Where should a filter-list "in" versus a filter-list "out" be applied?

A filter-list "in" will prevent type 3 summary LSAs from being created in this area. A filter-list "out" will stop any type 3 summary LSAs for any areas being created from this area.

74

What inputs does the filter-list command accept for matching?

prefix-list only

75

Where can a filter-list be applied that an "area...range...not-advertise" cannot?

A filter-list can be applied on any ABR. The "...not-advertise" command only works on the ABR within the area that contains the subnet in question.

76

Give the command to stop a network from leaving its area as a type 3 summary LSA.

router ospf 100
area # range x.x.x.x y.y.y.y not-advertise

77

How is a distribute-list used differently between EIGRP and OSPF?

In both, the distribute list keeps routes from entering the routing table. In EIGRP, the routing table is used to generate updates, but in OSPF, it is the link-state database. So, OSPF cannot prevent advertisement by using a distribute-list.

78

What directions can a filter-list impact OSPF? What directions can a distribute-list impact OSPF?

Filter-list can be in or out. Distribute-list is in only.

79

What are two requirements for performing summarization with OSPF?

The router must be an ABR or ASBR, and it must include at least one subnet live that's included in the summary.

80

Give the command to summarize a network in OSPF.

router ospf 100
area # range x.x.x.x y.y.y.y

81

With an OSPF LSA summarization, how is the cost determined if not explicitly specified?

The cost is taken from the lowest LSA matching inside the summary.

82

What area should be used with an OSPF summarization using "area # range..."?

The area where the LSAs to be summarized exist.

83

What makes a router an ASBR?

An autonomous system border router redistributes routes from another protocol (static, EIGRP, etc.) into OSPF.

84

Which routers can summarize redistributed routes?

The originating ASBR only. The ABR for the area cannot.

85

Explain the difference between the "area # range..." and "summary-address" commands.

"Area # range..." is used for summarizing OSPF LSAs on ABRs. "Summary-address" is used on ASBRs to summarize non-OSPF routes.

86

Give the command to summarize redistributed routes on an ASBR.

router ospf 100
summary-address x.x.x.x y.y.y.y

87

Give two ways to inject a default route into OSPF.

"default-information originate" or make an area a stub

88

What does 'default-information originate' do?

It will create an LSA for a default route from whatever the default route is in the routing table, regardless of which protocol it originated from.

89

What type of LSA is generated as a result of "default-information originate", and what is the default cost?

A type 5 external LSA with a sub-type 2 route. The default cost is one.

90

Give the commands to change the sub-type of LSA and cost with a default route.

default-information originate metric-type 1/2
default-information originate metric #

91

How can a default route only be advertised under certain conditions?

A default route can be advertised only when route-map criteria are met, if so desired.

default-information originate route-map

92

Do all routers in an area have to be configured as stub routers? Do all routers in an area have to be configured as totally stubby areas?

Yes, all routers must be stub routers.

No, only the ABR must be configured to indicate the stub area is totally stubby.

93

Can a stub area include an ASBR?

No, because no type 5 external network LSAs are permitted.

94

Give the command to configure a stubby area.

router ospf 100
area # stub

95

Give the command to configure a totally stubby area.

* ABR Only *

router ospf 100
area # stub no-summary

96

Give the four stub area types.

stub, totally stubby, not so stubby, totally not-so-stubby

97

Which stub types receive type 3 LSAs?

Stubby and not-so-stubby areas receive type 3 summary LSAs.

98

Give the command to change the cost of the default route sent into a totally stubby area.

router ospf 100
area # default-metric #

99

What type of LSA is sent into totally stubby areas as a default route and what is the default metric?

A type 3 summary LSA with a metric of one.

100

Can type 5 LSAs be filtered with a filter-list?

No, type 5 external LSAs cannot. They are flooded to every router except stub areas.

101

What is a NSSA?

A not-so-stubby area is a stub area that can contain an ASBR.

102

What type of LSAs do ASBRs in NSSA areas send?

type 7 NSSA external LSAs

103

Which type 3 LSAs do totally stubby and totally not-so-stubby areas receive?

The default route only as a type 3 summary LSA

104

Give the command to turn an area into a NSSA.

router ospf 100
area # nssa

105

Give the command to turn an area into a totally NSSA.

* ABR only *

router ospf 100
area # nssa no-summary

106

What is a virtual link used for?

A virtual link is used to extend area zero by joining two ABRs that do not connect over area zero.

107

What is a prerequisite for two routers to share a virtual link?

They must have a common area (that is not area zero and is not a stub area).

108

How are virtual link packets sent?

unicast

109

What address is used to terminate a virtual link?

the router-id

110

How long do LSAs sent over a virtual link last before aging out?

They do not age. The LSAs are not periodically re-sent.

111

Give the command to configure a virtual link.

router ospf 1
area # virtual-link

112

What area number should be used in a virtual link configuration?

The transit area that both routers share.

113

Give the command to see virtual links.

sh ip ospf virtual-links

114

Give the command to configure plaintext authentication over a virtual-link.

router ospf 100
area # virtual-link x.x.x.x authentication-key Cisco

115

Give the command to configure md5 authentication over a virtual-link.

router ospf 100
area # virtual-link x.x.x.x authentication message-digest message-digest-key # md5

116

Give four ways to change the routing path amongst areas.

1. cost on the interface
2. summary route
3. filtering
4. change metric type (type 1 vs. type 2)

117

Give three ways to change the routing path within an area.

1. change the reference bandwidth (auto-cost reference)
2. change the bandwidth of an interface
3. change the cost of an interface

118

How often are Hellos exchanged on a virtual-link?

They stop being exchanged after the link is initialized.