IOS Commands Flashcards Preview

ICND1 100-101 > IOS Commands > Flashcards

Flashcards in IOS Commands Deck (127)
Loading flashcards...
1

line console 0

Global command that changes the context to console configuration mode.

2

line vty

Global command that changes the context to vty configuration mode for the range of vty lines listed in the command.

3

login

Line (console and vty) configuration mode. Tells IOS to prompt for a password (no username).

4

password

Line (console and vty) configuration mode. Lists the password required if the login command (with no other parameters) is configured.

5

interface

Global command that changes the context to interface mode - for example, interface FastEthernet 0/1

6

hostname

Global command that sets this switch's host name, which is also used as the first part of the switch's command prompt.

7

exit

Moves back to the next higher mode and goes back to enable mode from any of the configuration submodes.

8

Ctrl-Z

This is not a command, but rather a two-key combination that together do the same thing as the end command

9

end

Exits configuration mode and goes back to enable mode from any of the configuration submodes.

10

no debug all
undebug all

Enable mode EXEC command to disable all currently enabled debugs.

11

terminal monitor

EXEC command that tells Cisco IOS to send a copy of all syslog messages, including debug messages, to the Telnet or SSH user who issues this command.

12

reload

Enable mode EXEC command that reboots the switch or router.

13

copy

Enable mode EXEC command that copies files from one file location to another. Locations include the startup config and running config in RAM, files TFTP and RCP servers, and flash memory.

14

copy running-config startup-config

Enable mode EXEC command that saves the active config, replacing the startup config file used when the switch initializes.

15

copy startup-config running-config

Enable mode EXEC command that merges the startup config file with the currently active running config file in RAM.

16

show running-config

Lists the contents of the running config file.

17

write erase
erase startup-config

These enable mode EXEC commands to erase the startup config file.

18

quit

EXEC command that disconnects the user from the CLI session.

19

show startup-config

Lists the contents of the startup config (initial config) file.

20

enable

Moves the user from user mode to enable (privileged) mode and prompts for a password if one is configured.

21

disable

Moves the user from enable mode to user mode.

22

configure terminal

Enable mode command that moves the user into configuration mode.

23

login local

Console and vty configuration mode. Tells IOS to prompt for a username and password, to be checked against locally configured username global configuration commands on this switch or router.

24

username secret

Global command. Defines one of possibly multiple usernames and associated passwords, used for user authentication. Used when the login local line configuration command has been used.

25

crypto key generate rsa

Global command. Creates and stores (in a hidden location in flash memory) the keys required by SSH.

26

transport input {telnet | ssh | all | none}

vty line configuration mode. Defines whether Telnet and/or SSH access is allowed into this switch. both values can be configured on one command to allow both Telnet and SSH access (the default).

27

service password-encryption

Global command that (weakly) encrypts passwords defined by the "username password", "enable password", and "login" commands.

28

interface vlan

Changes the context to VLAN interface mode. For VLAN1, allows the configuration of the switch's IP address.

29

ip address

VLAN interface mode. Statically configures the switch's IP address and mask.

30

ip address dhcp

VLAN interface mode. Configures the switch as a DHCP client to discover its IP address, mask, and default gateway.

31

ip default-gateway

Global command, Configures the switch's default gateway IP address. Not required if the switch uses DHCP.

32

ip name-server

Global command. Configures the IP address(es) of DNS servers, so any commands when logged into the switch will use the DNS for name resolution.

33

interface

Changes context to interface mode. The type is typically FastEthernet or GigabitEthernet. The possible port numbers vary depending on the model of switch - for example, Fa0/1, Fa0/2, and so on.

34

interface range

Changes the context to interface mode for a range of consecutively numbered interfaces. The sub-commands that follow then apply to all interfaces in the range.

35

shutdown
no shutdown

Interface mode. Disables or enables the interface, respectively.

36

speed {10 | 100 | 1000 | auto}

Interface mode. Manually sets the speed to the listed speed or, with the auto setting, automatically negotiates the speed.

37

duplex {auto | full | half}

Interface mode. Manually sets the duplex to half or full, or to auto-negotiate the duplex setting.

38

description

Interface mode. Lists any information text that the engineer wants to track for the interface, such as the expected device on the other end of the cable.

39

switchport mode {access | trunk | negotiate}

Interface configuration mode command that tells the switch to always be an access port, or always be a trunk port, or to negotiate which to be.

40

switchport port-security mac-address

Interface configuration mode command that statically adds a specific Mac address as an allowed MAC address on the interface.

41

switchport port-security mac-address sticky

Interface sub-command that tells the switch to learn MAC addresses on the interface and add them to the configuration for the interface as secure MAC addresses.

42

switchport port-security maximum

Interface sub-command that sets the maximum number of static secure MAC addresses that can be assigned to a single interface.

43

switchport port-security violation {protect | restrict | shutdown}

Interface sub-command that tells the switch what to do if an inappropriate MAC address tries to access the network through a secure switch port.

44

hostname

Global command. Sets this switch's host name, which is also used as the first part of the switch's command prompt.

45

enable secret

Global command. Sets this switch's password that is required for any user to reach enable mode.

46

history size

Line config mode. Defines the number of commands held in the history buffer, for later recall, for users of those lines.

47

logging synchronous

Console or vty mode. Tells IOS to send log messages to the user at natural break points between commands, rather than in the middle of a line of output.

48

[no] logging console

Global command that disables or enables the display of log messages to the console.

49

exec-timeout

Consoles or vty mode. Sets the inactivity timeout, so that after the defined period of no action, IOS closes the current user login session.

50

switchport access vlan

Interface sub-command that defines the VLAN in which the interface resides.

51

banner [motd | exec | login]

Global command that defines a banner that is displayed at different times when users log in to the switch or router.

52

show running-config

Lists the currently used configuration.

53

show running-config | begin line vty

Pipes (sends) the command output to the begin command, which only lists output beginning with the first line that contains the text "line vty."

54

show mac address-table dynamic

Lists the dynamically learned entries in the switch's address (forwarding) table.

55

show dhcp lease

Lists any information the switch acquires as a DHCP client. This includes IP address, subnet mask, and default gateway information.

56

show crypto key mypubkey rsa

Lists the public and shared key created for use with SSH using the crypto key generate rsa global configuration command.

57

show ip ssh

Lists status information for the SSH server, including the SSH version.

58

show ssh

Lists status information for current SSH connections into and out of the local switch.

59

show interfaces status

Lists one output line per interface, noting the description, operating state, and settings for duplex and speed on each interface.

60

show interfaces vlan 1

Lists the interface status, the switch's IP address and mask, and much more.

61

show ip default-gateway

Lists the default gateway.

62

show port-security interface

Lists an interface's port security configuration settings and security operation status.

63

terminal history size

Changes the length of the history buffer for the current user only, only for the current login to the switch.

64

show history

Lists the commands in the current history buffer.

65

vlan

Global config command that both creates the VLAN and puts the CLI into VLAN configuration mode.

66

name

VLAN sub-command that names the VLAN

67

[no] shutdown

VLAN mode sub-command that enables (no shutdown) or disables (shutdown) the VLAN

68

[no] shutdown vlan

Global config command that has the same effect as the [no] shutdown VLAN mode subcommands

69

vtp mode {server | client | transparent | off}

Global config command that defines the VTP mode

70

switchport mode {access | dynamic | auto | desirable | trunk}

Interface sub-command that configures the trunking administrative mode on the interface

71

switchport access vlan

Interface sub-command that defines the list of allowed VLANs

72

switchport trunk {dot1q | isl | negotiate}

Interface sub-command that defines which type of trunking to use, assuming that trunking is configured or negotiated

73

switchport trunk native vlan

Interface sub-command that defines the native VLAN for a trunk port

74

switchport nonegotiate

Interface sub-command that disables the negotiation of VLAN trunking

75

show interfaces switchport

Lists information about any interface regarding administrative settings and operational state

76

show interfaces trunk

Lists information about all operational trunks (but no other interfaces), including the list of VLANs that can be forwards over the trunk

77

show vlan [brief | id | name | summary]

Lists information about the VLAN

78

show vlan [vlan]

displays VLAN information

79

show vtp status

Lists VTP configuration and status information

80

shutdown
no shutdown

Interface sub-commands that administratively disable and enable an interface, respectively.

81

switchport port-security violation {protect | restrict | shutdown}

Interface sub-command that tells the switch what to do if an inappropriate MAC address tries to access the network through a secure switch port.

82

cdp run
no cdp run

Global commands that enable and disable, respectively, CDP for the entire switch or router.

83

cdp enable
no cdp enable

Interface sub-commands that enable and disable, respectively, CDP for a particular interface.

84

speed {auto | 10 | 100 | 1000}

Interface sub-command that manually sets the interface speed.

85

duplex {auto | full | half}

Interface sub-command that manually sets the interface duplex.

86

show mac address-table [dynamic | static] [address ] [interface ] [vlan ]

Displays the MAC address table. The security option displays information about the restricted or static settings.

87

show port-security [interface ] [address]

Displays information about security options configured on an interface.

88

show cdp neighbors []

Lists one summary line of information about each neighbor, or just the neighbor found on a specific interface if an interface was listed.

89

show cdp neighbors detail

Lists one large set of information (approximately 15 liens) for every neighbor.

90

show cdp entry

Displays the same information as the "show cdp neighbors detail" command, but only for the named neighbor.

91

show cdp

States whether CDP is enabled globally, and lists the default update and holdtime timers.

92

show cdp interface [type number]

States whether CDP is enabled on each interface, or a single interface if the interface is listed, and states update and holdtime timers on those interfaces.

93

show cdp traffic

Displays global statistics for the number of CDP advertisements sent and received.

94

show interfaces [type number]

Displays detailed information about interface status, settings, and counters.

95

show interfaces description

Displays one line of information per interface, with a two-item status (similar to "show interfaces" command status), and includes any description that is configured on the interface.

96

show interfaces [ ] status

Displays summary information about interface status and settings, including actual speed and duplex, a single-item status code, and whether the interface was auto-negotiated.

97

show interfaces [

Displays a large variety of configuration settings and current operational status, including VLAN trunking details, access and voice VLAN, and native VLAN.

98

show interfaces [ ] trunk

Lists information bout the currently operational trunks (or just for the trunk listed in the command) and the VLANs supported on those trunks.

99

show vlan brief,
show vlan

Lists each VLAN and all interfaces assigned to that VLAN but does not include trunks.

100

show vlan id

Lists both access and trunk ports in the VLAN

101

show vtp status

Lists the current VTP status, including the current mode.

102

interface

Global command that moves the user into configuration mode of the named interface

103

ip address

Interface sub-command that sets the router's IPv4 address and mask.

104

[no] shutdown

Interface sub-command that enables (no shutdown) or disables (shutdown) the interface.

105

duplex {full | half | auto}

Interface command that sets the duplex, or sets the use of IEEE autonegotiation, for router LAN interfaces that support multiple speeds.

106

speed {10 | 100 | 1000}

Interface command for router Gigabit (10/100/1000) interfaces that sets the speed at which the routers interface sends and receives data.

107

clock rate

interface command that sets the speed at which the router supplies a clocking signal, applicable only when the router has a DCE cable installed. the unit it bits/second.

108

description

An interface sub-command with which you can type a string of text to document information about that particular interface.

109

show interfaces [ ]

Lists a large set of informational messages about each interface, or about the one specifically listed interface.

110

show ip interface brief

Lists a single line of information about each interface, including the IP address, line and protocol status, and the method with which the address was configured (manual or DHCP).

111

show protocols

Lists information about the listed interface, including the IP address, mask, and line/protocol status.

112

show controllers [ ]

Lists many lines of information per interface, or for one interface, for the hardware controller of the interface. On serial interfaces, this command identifies the cable as either a DCE or DTE cable.

113

show version

Lists the version of IOS currently running in the router, plus a variety of other facts about the currently installed hardware and software in the router.

114

ip address [secondary]

Interfaces sub-command that assigns the interface's IP address and optionally makes the address a secondary address.

115

interface

Global command to create a subinterface and to enter configuration mode for that subinterface

116

encapsulation dot1q [native]

A subinterface sub-command that tells the router to use 802.1Q trunking, for a particular VLAN, and with the native keyword, to not encapsulate the header

117

encapsulation isl

A subinterface subcommand that tells the router to use ISL trunking for a particular VLAN

118

sdm prefer lanbase-routing

A command on Cisco switches that enables the switch to support IP routing if configured

119

[no] ip routing

Global command that enables (ip routing) or disables (no ip routing) the routing of IPv4 packets on a router or Layer 3 switch

120

interface vlan

Global command on a Layer 4 switch to create a VLAN interface and to enter configuration mode for that VLAN interface

121

[no] ip subnet-zero

Global command that allows (ip subnet-zero) or disallows (no ip subnet-zero) the configuration of an interface IP address in a zero subnet

122

ip route { } [] [permanent]

Global configuration command that creates a static route

123

ip default-network

Global command that creates a default route based on the router's route to reach the classful network listed in the command.

124

show ip route

Lists the router's entire routing table

125

show ip route [connected | static | ospf]

Lists a subnet of the IP routing table

126

show ip route

Lists detailed information about the route that a router matches for the listed IP address

127

show vlans

Lists VLAN configuration and statistics for VLAN trunks configured on routers