Lecture 8: Open Shortest Path First Flashcards
(28 cards)
What does OSPF stand for?
Open Shortest Path First
What type of routing protocol is OSPF?
Link-state.
What metric does OSPF use?
Bandwidth (cost = reference bandwidth / interface bandwidth)
What’s the purpose of DR and BDR?
Reduce OSPF traffic on multi-access networks.
Command to start OSPF process with ID 1?
router ospf 1
Command to advertise a network in Area 0?
network <ip> <wildcard> area 0</wildcard></ip>
What is OSPF and how does it differ from RIP?
OSPF (Open Shortest Path First) is a link-state routing protocol that uses bandwidth to calculate the best path, rather than hop count like RIP. It converges faster, supports areas for scalability, and maintains a complete map of the network.
What are the limitations of RIP?
*Uses hop count as the only metric (max 15 hops).
*Slow convergence.
*No consideration of bandwidth or delay.
*Not scalable for large networks.
What are the main components/tables in OSPF and how are they built?
*Adjacency Table – built using Hello packets.
*Topology Table – contains LSAs from other routers.
*Routing Table – computed using SPF (Dijkstra) algorithm from the topology table.
What are Hello packets in OSPF and what are their default settings?
*Sent every 10 seconds by default.
*Used to discover and maintain neighbor relationships.
*If no Hello is received for 4 intervals (40s), the neighbor is considered dead.
What are LSAs and LSUs in OSPF?
LSA (Link-State Advertisement): Information about router links and metrics.
LSU (Link-State Update): Packet that carries LSAs to other routers.
What is the DR/BDR election and when is it used?
On multi-access networks (like Ethernet), OSPF elects:
*DR (Designated Router) – central point for LSA exchange.
*BDR (Backup Designated Router) – takes over if DR fails.
Election is based on router priority and Router ID.
How is OSPF cost calculated and why is it important?
Formula: Cost = Reference Bandwidth / Interface Bandwidth
*Default reference bandwidth = 100,000,000 bps (100 Mbps).
*Lower cost = better path.
Example:
10 Gbps ⇒ Cost = 1
1 Gbps ⇒ Cost = 100
100 Mbps ⇒ Cost = 1000
What are Process ID, Area ID, and Router ID in OSPF?
Process ID: Local identifier of an OSPF process (can be any number).
Area ID: Identifies an OSPF area (e.g., Area 0 = backbone).
Router ID: Unique 32-bit identifier (preferably highest IP, or manually set).
How do you start OSPF and advertise a network in Cisco IOS?
router ospf 1
network 10.10.1.1 0.0.0.0 area 0
How do you manually set the Router ID and interface priority?
router ospf 1
router-id 1.1.1.1
ip ospf priority 200
How do you enable OSPF on an interface and specify area?
interface g0/0
ip ospf 10 area 0
How do you set the OSPF network type to point-to-point?
interface g0/0
ip ospf network point-to-point
How can you adjust the reference bandwidth in OSPF?
router ospf 10
auto-cost reference-bandwidth <Mbps></Mbps>
How can you manually set the OSPF cost of an interface?
interface g0/0
ip ospf cost <value></value>
How do you change the Hello and Dead Intervals on an interface?
interface g0/0
ip ospf hello-interval <seconds>
ip ospf dead-interval <seconds></seconds></seconds>
How do you configure default route propagation in OSPF?
ip route 0.0.0.0 0.0.0.0 s0/0/0
router ospf 10
default-information originate
What does show ip ospf neighbors command display?
Neighbor IP addresses.
Router IDs.
Adjacency states (e.g., FULL).
DR/BDR status.
Priority values.
What info is shown with show ip protocols?
OSPF process ID.
Router ID.
Interfaces running OSPF.
Administrative distance.
Timers.